[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling namazu

Another follow-up:

I did remove references to getopt in the lib/Makefile and got the following errors:

ld: Undefined symbols:
make[2]: *** [namazu] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2

So, to summarize: even when I remove all references to -lm, the system still includes a version of getopt so I get a multiple definition error. If I remove the local version of getopt, I get an undefined symbol error.

Any ideas on how I can compile namazu under OS X 10.2.6?

Thanks for any help,


On Wednesday, June 4, 2003, at 10:37  PM, Kris Jensen wrote:

I've found several other references to this issue on the web (not with respect to namazu, but with other packages).

Apparently, the configure script doesn't detect that getopt is included in the Mac OS X system (even after removing references to -lm, the error appears with a reference to a definition in "/usr/lib/libSystem.dylib(getopt.So)")

I tried removing getopt.c from the Makefile in /lib, but I must not have done it effectively because Make still created getopt.o and I still got the error message.

Thanks for any help in getting namazu to compile...

Kris Jensen

On Wednesday, June 4, 2003, at 07:17  PM, Makoto Fujiwara wrote:

In the mail,
  To: mharc-users@xxxxxxxxxxx
  Cc: namazu-users-en@xxxxxxxxxx
  From: Earl Hood <earl@xxxxxxxxxxxx>
  Date: Tue, 03 Jun 2003 23:04:12 -0500

ewh> On June 3, 2003 at 19:30, Kris Jensen wrote:
I believe this issue is addressed in this thread from the
namazu-users-ja mailing list:

I had tried to duplicate the problem, but I was not able to boot my OS X environment, so I just picked up the article telling nasty work arround, in (Dated Apr. 4,2001)

(1) DO ./configure
(2) EDIT nmz/Makefile arround the 148th line.
   < LIBS = -lm
(3) DO make

(Not totally tested on my environment, sorry)
Makoto Fujiwara,
Chiba, Japan, Narita Airport and Disneyland prefecture.