[Namazu-users-ja 959] Re: namazu 2.0.14 -> 17で、一太郎ファイルでセグメンテーション違反

Yukio USUDA m6694ha392t @ asahi-net.or.jp
2007年 3月 18日 (日) 02:01:15 JST


臼田です

On 2007/03/18, at 0:31, Keiji Watanabe wrote:

>
> ・nkf-1.92-6
> ・kakasi-2.3.2-4
>
> これに2年前、namazu 2.0.14をインストールしました。
>
> ・namazu 2.0.14インストール
> ・lv451インストール
> ・Vine Linuxの libwmf-0.2.6-0vl1をインストール
> ・Vine Linuxの xlHtml-0.2.8-0vl0をインストール
> ・rtf2htmlをインストール
> ・OLE-Storage_Lite-0.14をインストール
> ・IO-stringry-2.110をインストール
> ・xpdf-3.00をインストール
>
perl のバージョンは何でしょうか。

nkf, kakasi, xlHtml のバージョンは新しくしたほうが
よいかと思います。
mknmz 実行中にセグメンテーション違反がおきるのは
これらのバージョンが古いときが多いです。


> 今回、namazu 2.0.17へのバージョンアップをするため、単純に 
> namazuを
> ./configure, make, make installしただけです。
>
> これまではうまくいっていたので、namazu本体の不具合では? 
> と思うの
> ですが、いかがでしょうか?
>
> # これまではスキップされていた文書なのに、今回がんばって読み取 
> ろうと
> # して、失敗してるのかもしれません。
> # でも、せめてそのファイルのみスキップしてほしいです...

2.0.14から2.0.17では
一太郎7以上用のフィルタはほとんど修正していませんので
動作は変わっていないはずです。
一太郎5,6用のフィルタでは無限ループに入るバグの修正と
外字を除去する修正をしています。


>>
>> セグメンテーション違反になる一太郎ファイルが特定できるようで 
>> したら
>> サンプルを送っていただければ調べてみます。
>>
> MLに流してよいかどうかお客様に確認中です。
> 許可が下りた際はよろしくお願いします。

MLでなく個人宛に送っていただければ結構です。

ちなみに停止したときに表示されているファイルは処理が完了している
ものなので、問題のあるファイルの名前は画面に表示されません。
エラーの出るファイルを特定する際には確認をお願いします。

臼田幸生




Namazu-users-ja メーリングリストの案内