[Namazu-users-en] Re: [ (can't open the index) ]] (Solved!)

rex rex at nosyntax.com
Mon Apr 9 15:57:40 JST 2007

rex <rex at nosyntax.com> [2007-04-07 21:19]:
> Synopsis: namazu.cgi cannot find the index (NMZ.*) files.
> namazu run from the command line works. 
> Example:
> namazu "amazons and dawson" /srv/www/htdocs/ffarchive 
> Results:
> References:  [ amazons: 1052 ]  [ dawson: 1026 ]
>  Total 35 documents matching your query.

I solved the problem with a hack. No matter what I tried for the idxname
in /srv/www/htdocs/ffarchive/index.html, the index files (NMZ*) were not
found. I tried every name and path in "idxname= ..." that seemed
reasonable with the identical result:


The response always is:

References: [ (can't open the index) ] 

Reading the documentation for the Nth time, I noticed this line:

"If you omit index, namazu will assume /usr/local/var/namazu/index as target."

I thought, "OK, if I can't insert the path namazi.cgi needs to find the
index files, I can remove the idxname setting from index.html and copy the
index files to the default location." I did that and it works. 

Since I was unable to make namazu.cgi find the index files no matter
what I set idxname= to, there may be a bug in namazu.cgi. If the web
search works in version 2.0.17 for anyone with the index files NOT in
the default location (/usr/local/var/namazu/index/) then there isn't a
bug. If it DOES work for someone, please post the relevant section of
your index.html file. Mine (which does not work) is:

<title>Freeflight List Archives</title>
<link rel="stylesheet" type="text/css" href="/archive/html/stylesheet_00.css">
<h1>Freeflight Archives</h1>
<form method="get" action="/cgi-bin/namazu.cgi">
<p><strong>Search String:</strong>
<input type="text" name="query" size="40">
<input type="submit" name="submit" value="Search!">
<input type="hidden" name="idxname" value="ffarchive">
<a href="namazu.cgi?idxname=ffarchive">[How to search]</a><br>

After removing the last two lines above and inserting:

<a href="namazu.cgi?">[How to search]</a><br>

searches work (the NMZ.* files that previously were in
/srv/www/htdocs/ffarchive are now in 
/usr/local/var/namazu/index/ )

I hope this helps someone...


More information about the Namazu-users-en mailing list