[Namazu-users-en] Re: some queries failing (cgi)

Chad Leigh -- Shire.Net LLC chad at shire.net
Sat Jun 18 01:56:07 JST 2005


On Jun 17, 2005, at 1:58 AM, Tadamasa Teranishi wrote:

> Tadamasa Teranishi wrote:
>
>>
>> It seems that another limitations except namazu.cgi hang if it
>> operates normally when executing it by using same namazu.cgi in
>> the command line.
>> The cause is not hit on ..what another has...
>>
>
> If contents of error_log,

[Fri Jun 17 10:50:48 2005] [error] [client 67.161.222.227] Premature  
end of script headers: /web/xxxxx.com/mailman/cgi-bin/Admin-List/ 
namazu.cgi
[Fri Jun 17 10:50:49 2005] [error] [client 67.161.222.227] Premature  
end of script headers: /web/xxxxx.com/mailman/cgi-bin/Admin-List/ 
namazu.cgi



> suexec.log,

when running as mailman, here is the content of suexec.log

[2005-06-17 10:41:46]: info: (target/actual) uid: (mailman/mailman)  
gid: (mailman/mailman) cmd: namazu.cgi
[2005-06-17 10:41:48]: info: (target/actual) uid: (mailman/mailman)  
gid: (mailman/mailman) cmd: namazu.cgi
[2005-06-17 10:46:14]: info: (target/actual) uid: (mailman/mailman)  
gid: (mailman/mailman) cmd: namazu.cgi
[2005-06-17 10:46:15]: info: (target/actual) uid: (mailman/mailman)  
gid: (mailman/mailman) cmd: namazu.cgi


when running as nobody, which is what the main apache runs as, suexec  
is not being used and we do not get entries in the suexec

> and http.conf are seen,

User and Group are shown turned off for testing without suExec.   
Normally they are on.  Same error both ways.

<VirtualHost 166.70.252.251:80>
     SSLDisable
#    User mailman
#    Group mailman
     ServerAdmin webmaster at xxxxx.com
     DocumentRoot /web/xxxxx.com/mailman/htdocs
     ServerName mailman.xxxxx.com
     ServerAlias mailman.xxxxx.com mailman.xxxxx.shire.net
     ErrorLog /log/apache/mailman.xxxxx.com/error_log
     CustomLog /log/apache/mailman.xxxxx.com/access_log common
     <Directory /web/xxxxx.com/mailman>
         Options Indexes FollowSymLinks MultiViews
         #
         # This controls which options the .htaccess files in  
directories can
         # override. Can also be "All", or any combination of  
"Options", "FileInfo",
         # "AuthConfig", and "Limit"
         #
         AllowOverride None

         #
         # Controls who can get stuff from this server.
         #
         Order allow,deny
         Allow from all
     </Directory>
     <Directory /web/xxxxx.com/mailman/cgi-bin/>
         Options ExecCGI
     </Directory>
     ScriptAlias /mailman/ "/web/xxxxx.com/mailman/cgi-bin/"
     Alias /pipermail/ "/web/xxxxx.com/mailman/archives/private/"
     Alias /icons/ "/web/xxxxx.com/mailman/icons/"

     <Directory "/web/xxxxx.com/mailman/icons/">
         Options Indexes MultiViews
         AllowOverride None
         Order allow,deny
         Allow from all
     </Directory>


</VirtualHost>



> something might be understood.
>
> How do it become it if namazu.cgi is used without using suExec?

Same error and same error in the error_log

best regards
Chad

> -- 
> =====================================================================
> TADAMASA TERANISHI
> http://www.asahi-net.or.jp/~yw3t-trns/index.htm
> Key fingerprint =  474E 4D93 8E97 11F6 662D  8A42 17F5 52F4 10E7 D14E
>
> _______________________________________________
> Namazu-users-en mailing list
> Namazu-users-en at namazu.org
> http://www.namazu.org/cgi-bin/mailman/listinfo/namazu-users-en
>

---
Chad Leigh -- Shire.Net LLC
Your Web App and Email hosting provider
chad at shire.net




More information about the Namazu-users-en mailing list