[Namazu-users-en] Re: some queries failing (cgi)

Chad Leigh -- Shire.Net LLC chad at shire.net
Fri Jun 17 06:24:31 JST 2005


On Jun 16, 2005, at 3:19 PM, Earl Hood wrote:

> On June 16, 2005 at 14:55, "Chad Leigh -- Shire.Net LLC" wrote:
>
>
>> I can set the environment variables QUERY_STRING and SCRIPT_NAME at
>> the shell level and run namazu.cgi from the shell and it seems to
>> return valid html.
>>
>> Apache is 1.3.something
>>
>
> If things run okay from the command-line, it appears the problem
> is probably due to Apache configuration.  Check which modules are
> installed.

I was thinking along those lines but cannot see at all how an apache  
configuration would allow some queries to work and some queries not  
to work.  Unless apache is passing the query string wrong.  The  
apache is pretty stock.  After remaking the namazu index, new query  
strings started failing.

Unfortunately namazu.cgi can't be coaxed to write its output to the  
apache error log so one can see what it is doing wrong.

>
> You may want to build/install a vanilla apache installation on
> a test system to check things out and to make it easier to
> debug things.
>
> --ewh
>
> _______________________________________________
> Namazu-users-en mailing list
> Namazu-users-en at namazu.org
> http://www.namazu.org/cgi-bin/mailman/listinfo/namazu-users-en
>

---
Chad Leigh -- Shire.Net LLC
Your Web App and Email hosting provider
chad at shire.net




More information about the Namazu-users-en mailing list